System Requirements

LastPass currently supports the following web browsers, operating systems and mobile devices:

Operating Systems

  • Windows 2000
  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8
  • Mac OS X 10.4.11 (Firefox)
  • Mac OS X 10.5+
  • Linux

Web Browsers

  • Internet Explorer 6+
  • Firefox 2+
  • Safari 3+
  • Google Chrome
  • Opera 11+
  • IE Tab in Firefox (using IE Anywhere)
  • Maxthon

Tablets

* The LastPass app is available in the Google Play Store, as is an extension for Dolphin HD.  An extension for Firefox Mobile is also available.  While these apps should work on most Android based tablets, we cannot guarantee that they will be compatible on every tablet available.  If you have any questions or problems, contact our support team and we can let you know if your tablet will work with LastPass.

Mobile Devices

Users are strongly recommended to download and run the installer from our website on all browsers that you regularly use.